SYM Owners Forum

ATV Models => QuadRaider 600 => Topic started by: sisnik on May 17, 2010, 11:44:30 PM

Title: unhappy owner.....
Post by: sisnik on May 17, 2010, 11:44:30 PM
My quad is 18 month old has only 2200 Km but a lot of problems.

1. Electric starter broke at 1500 Km.
2. Horn is working sometimes.
3. The engine does not brakes the quad when I ride downhill.
4. Carburetor broke at 2100 Km and overflow the fuel.
5. When I use the "L" position in the gear box, a metallic noise is coming out.
    It looks like it will brake soon.
6. The exhaust broke 3 times till now.
Title: Re: unhappy owner.....
Post by: kapeo on December 13, 2010, 04:07:38 PM
Hey....
I think that you are very unlucky with your Quadrider.
I have it from 2009 and i have made 15.000km.
I dont have any problem.
I have tune it up with yamaha xt piston....
I have very strong acceleration and top speed....
Title: Re: unhappy owner.....
Post by: pjrv76 on June 29, 2011, 08:31:04 AM
Ol
Title: Re: unhappy owner.....
Post by: pjrv76 on June 29, 2011, 08:33:35 AM
1. Partida el
Title: Re: unhappy owner.....
Post by: quadraider 600 on December 26, 2011, 03:07:00 AM
hi hope all is well i find it very frustrating finding parts and info on these quads and sick of being overcharged for bits so just started a group on facebook to try and help each other please check it out its a new group but hopefully it will grow sym quadraider 600 atv           http://www.facebook.com/groups/287169391335666/ (http://www.facebook.com/groups/287169391335666/)