Author Topic: unhappy owner.....  (Read 14767 times)

sisnik

  • Newbie
  • *
  • Posts: 1
    • View Profile
unhappy owner.....
« on: May 17, 2010, 11:44:30 PM »
My quad is 18 month old has only 2200 Km but a lot of problems.

1. Electric starter broke at 1500 Km.
2. Horn is working sometimes.
3. The engine does not brakes the quad when I ride downhill.
4. Carburetor broke at 2100 Km and overflow the fuel.
5. When I use the "L" position in the gear box, a metallic noise is coming out.
    It looks like it will brake soon.
6. The exhaust broke 3 times till now.
« Last Edit: May 17, 2010, 11:49:58 PM by sisnik »

kapeo

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: unhappy owner.....
« Reply #1 on: December 13, 2010, 04:07:38 PM »
Hey....
I think that you are very unlucky with your Quadrider.
I have it from 2009 and i have made 15.000km.
I dont have any problem.
I have tune it up with yamaha xt piston....
I have very strong acceleration and top speed....

pjrv76

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: unhappy owner.....
« Reply #2 on: June 29, 2011, 08:31:04 AM »
Ol

pjrv76

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: unhappy owner.....
« Reply #3 on: June 29, 2011, 08:33:35 AM »
1. Partida el

quadraider 600

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unhappy owner.....
« Reply #4 on: December 26, 2011, 03:07:00 AM »
hi hope all is well i find it very frustrating finding parts and info on these quads and sick of being overcharged for bits so just started a group on facebook to try and help each other please check it out its a new group but hopefully it will grow sym quadraider 600 atv           http://www.facebook.com/groups/287169391335666/