Author Topic: no brake light on my 2008 RV250...  (Read 304 times)

SYMmike

  • Full Member
  • ***
  • Posts: 236
    • View Profile
    • Me
no brake light on my 2008 RV250...
« on: July 28, 2017, 01:35:00 PM »
I have tail lights but no brake lights.
I checked the brake switches already that are located at the brake lever.
They checked out ok. Does anyone else know what the problem could be and where its located??
I'm figuring the bulbs ok since the tail ligjts and brake lights and the same bulb.

Thanks in advance...
Mike
2008 dark grey RV250, 27,000 miles

Tromper

  • Sr. Member
  • ****
  • Posts: 348
    • View Profile
Re: no brake light on my 2008 RV250...
« Reply #1 on: July 28, 2017, 02:55:17 PM »
The bulbs are a great start, if they're not going then you can check if power's getting there or not & replace 'em or start tracing wiring back as appropriate.

I have tail lights but no brake lights.
I checked the brake switches already that are located at the brake lever.
They checked out ok. Does anyone else know what the problem could be and where its located??
I'm figuring the bulbs ok since the tail ligjts and brake lights and the same bulb.

Thanks in advance...
Mike
08 SYM HD200
07 Suzuki Burgman 650

SYMmike

  • Full Member
  • ***
  • Posts: 236
    • View Profile
    • Me
Re: no brake light on my 2008 RV250...
« Reply #2 on: July 28, 2017, 04:47:28 PM »
My brake light/rear lights are a LED which have 20 little bulbs. Since its LED the whole panel probably has to be replaced if they don't work. In my case, the tail lights work but they don't get brighter when I press on the brake. That's how they are supposed to work. My repair manual says to check for continuity in the brake switch which I don't have, BUT when I manually made a connection the brake lights still didn't work, so it must be something else. Any suggestions?
2008 dark grey RV250, 27,000 miles

SYMmike

  • Full Member
  • ***
  • Posts: 236
    • View Profile
    • Me
Re: no brake light on my 2008 RV250...
« Reply #3 on: July 31, 2017, 06:13:24 PM »
Ok, after further investigation the brake lights do work. they are on all the time. I can start the scooter without pressing on the brake. I disconnected the brake switches (both of them)at the levers and the scooter still started, so I must have continuity in the wiring harness somewhere. At least that's my determination. There is nothing else wrong with any lighting or anything on the scoot.
If anyone else had this kind of problem let me know what it was or what you did to fix it.
2008 dark grey RV250, 27,000 miles

SYMmike

  • Full Member
  • ***
  • Posts: 236
    • View Profile
    • Me
Re: no brake light on my 2008 RV250...
« Reply #4 on: August 02, 2017, 07:46:30 PM »
I narrowed it down to the tail light/brake light. I must have continuity between the tail light and brake light wire or since it's an LED light, continuity in the board somewhere.
Does anyone know where I can get a replacement???? I can't find it anywhere!
2008 dark grey RV250, 27,000 miles

Tromper

  • Sr. Member
  • ****
  • Posts: 348
    • View Profile
Re: no brake light on my 2008 RV250...
« Reply #5 on: August 03, 2017, 03:51:17 AM »
If it's an OEM part, Cam Purvis may be able to hook ya up.
http://www.scooterseals.com/
Email him if ya don't see it on his site.
08 SYM HD200
07 Suzuki Burgman 650

SYMmike

  • Full Member
  • ***
  • Posts: 236
    • View Profile
    • Me
Re: no brake light on my 2008 RV250...
« Reply #6 on: August 05, 2017, 04:30:04 PM »
If it's an OEM part, Cam Purvis may be able to hook ya up.
http://www.scooterseals.com/
Email him if ya don't see it on his site.

Thanks Tromper!!
I did find the part I need in a SYM warehouse in California. I could not order direct to get it so I went to my dealer for him to order it. The part alone is $150 so I will probably be paying $170 to $180 for the part. Waiting for the part now.....
2008 dark grey RV250, 27,000 miles

SYMmike

  • Full Member
  • ***
  • Posts: 236
    • View Profile
    • Me
Re: no brake light on my 2008 RV250...
« Reply #7 on: August 17, 2017, 06:35:20 PM »
Ok, I installed the new tail/brake light and everything works normal now!! YEAH!!
I posted two pics of the old tail light/brake light. the 4 screws you see on the back loosens the circuit board for the lights, BUT you cannot remove it out of the casing. Its a sealed system to keep moisture out & there is no way to get to the circuit board/lights unless you cut out the lens. The 4 screws has little gaskets on the screw heads which were dry rotted and falling apart. So moisture must have got to the circuit board.


2008 dark grey RV250, 27,000 miles