Author Topic: How to reset EFI error code after replacing battery on Joyride 200  (Read 108 times)

bobgr46

  • Newbie
  • *
  • Posts: 2
    • View Profile
I replaced the battery on my 2012 Joyride 200 3 days ago and on turning on the ignition the Efi lamp on the instrument panel flashed as follows; o o    o o o o o o o o   o o
The bike started OK and ran for a while then suddenly cut out. Ignition off/on and it started and ran OK again.
Is there a valid reason for this, i.e. does the Efi unit "issue" an error code due to the (old)battery low voltage or has something got to be reset due to the new higher battery voltage/current.
Battery standing voltage is 12.85v & charging is above 13.15v above idle speed.
If so, is there a reset sequence for resetting the Efi unit?
Can anyone help as I don't now have a local Sym dealer with the relevant information or diagnostic software

redridinghood

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Re: How to reset EFI error code after replacing battery on Joyride 200
« Reply #1 on: July 23, 2017, 08:05:07 AM »
Before you replaced the battery, there were no symptoms related to the engine light or engine cutting out...correct?

When the engine cut out,  did you happen to notice if the lights that would normally be lit with the key on, engine not running, were still lit?

If the engine cuts out again, take a look at these lights, with the key still on and before trying to restart.

I would disconnect the negative cable of the battery, as this should reset any trouble codes...

And since this appears to have begun after the replacement of the battery, go ahead and disconnect both cables and with a fine wire brush (auto parts stores have these) clean the battery terminals and cables until they are shiny and reconnect them...
 


 

« Last Edit: July 23, 2017, 08:23:19 AM by redridinghood »

bobgr46

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: How to reset EFI error code after replacing battery on Joyride 200
« Reply #2 on: July 24, 2017, 07:49:22 AM »
Thanks for the suggestions "redridinghood" but, embarrassing to say the least, but on investigating the problem I found the following:
When replacing the battery cover behind the right side outer panel, I found that because there is minimal accessibility for refitting this cover, the cover's cutout for the battery positive terminal was pressed against the cable when attempting to secure it (there is an additional connector for a Beltran "Batter Tender/charger also fitted here) and actually slightly loosened the connector....!
I modified (enlarged)the cover cutouts to accommodate the additional cables on both terminals which has ultimately solved the problem.
I suggest that the battery cover cutouts are suitably enlarged before adding any additional cables to the battery terminals! You have been warned!!! :)

redridinghood

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Re: How to reset EFI error code after replacing battery on Joyride 200
« Reply #3 on: July 24, 2017, 05:21:47 PM »
👌🏼😉